Home > An Error > Gcc Error 136

Gcc Error 136

Contents

Results logged to /Users/chris/.rvm/gems/[email protected]/gems/libv8-3.16.14.3/ext/libv8/gem_make.out An error occurred while installing libv8 (3.16.14.3), and Bundler cannot continue. Reload to refresh your session. I’m having problems using ‘standard’ (xcode?) gcc, and both apple-gcc42 and gcc from homebrew. Info(const v8::AccessorInfo& info); ^~~~~~~~~~~~~~~~ Accessor ./rr.h:456:7: note: 'Accessor' declared here class Accessor { ^ ./rr.h:488:18: error: no type named 'AccessorInfo' in namespace 'v8'; did you mean 'Accessor'?

static v8::Handle AccessorGetter(v8::Local property, const v8::AccessorInfo& info); ^~~~~~~~~~~~~~~~ Accessor ./rr.h:456:7: note: 'Accessor' declared here class Accessor { ^ ./rr.h:507:96: error: no type named 'AccessorInfo' in namespace 'v8'; did you mean 'Accessor'? We recommend upgrading to the latest Safari, Google Chrome, or Firefox. How to handle a senior developer diva who seems unaware that his skills are obsolete? Results logged to /Users/chris/.rvm/gems/[email protected]/gems/libv8-3.16.14.3/ext/libv8/gem_make.out An error occurred while installing libv8 (3.16.14.3), and Bundler cannot continue. https://github.com/cowboyd/libv8/issues/131

An Error Occurred While Installing Therubyracer (0.12.2), And Bundler Cannot Continue.

Completely scratching my head, and already wasted hours on this. This could take a while... Bug136 - Internal compiler error in const_hash Summary: Internal compiler error in const_hash Status: RESOLVED FIXED Alias: None Product: gcc Classification: Unclassified Component: c++ (show other bugs) Version: 2.95.2 Importance: P3 Just look for the file thisroot.sh with your nautilus.

Any other suggestions? krazyjakee commented Aug 4, 2014 I'm still getting an issue only with this gem. yes creating Makefile make compiling accessor.cc clang: warning: argument unused during compilation: '-rdynamic' In file included from accessor.cc:1: ./rr.h:463:14: error: no type named 'AccessorGetter' in namespace 'v8' inline v8::AccessorGetter accessorGetter() {return Error Installing Therubyracer Do we have a solution?

OK. Collaborator ignisf commented Jan 5, 2015 @dankozlowski yes -- this issue was fixed by #124, please update your version of libv8 ignisf locked and limited conversation to collaborators Jan 5, 2015 Please don't fill out this field. When moving from this to install therubyracer, it still shows that there is no officially supported v8 compiler.

I encounter this issue with ruby and libv8. Gem Install Therubyracer El Capitan So far the instructions have been pretty easy to follow along. It is recommended to use GCC v4.4 or higher Using compiler: g++ Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/usr/include/c++/4.2.1 Unable to find a compiler officially supported by v8. assuming you use rbenv: rbenv versions system * 1.8.7-p354 2.0.0-rc2 rbenv uninstall 1.8.7-p354 rbenv install 1.8.7-p375 rbenv versions system * 1.8.7-p375 2.0.0-rc2 bundle install share|improve this answer answered Apr 5 '14

Checking For V8.h... No

Meaning of "oh freak" more hot questions question feed lang-c about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / https://root.cern.ch/phpBB3/viewtopic.php?t=21393 My build directory is ~/programs/rootbuild/ .Any further help would be appreciated! An Error Occurred While Installing Therubyracer (0.12.2), And Bundler Cannot Continue. Linux users Install node.js. An Error Occurred While Installing Libv8 (3.16.14.3), And Bundler Cannot Continue. Related 1Unable to install therubyracer162Installing libv8 gem on OS X 10.9+49therubyracer - Gem::Ext::BuildError: ERROR: Failed to build gem native extension71How to install therubyracer gem on 10.10 Yosemite?0Failed to build gem native

ERROR: Error installing libv8: ERROR: Failed to build gem native extension. /Users/edolyne/.rvm/rubies/ruby-2.1.2/bin/ruby extconf.rb creating Makefile Compiling v8 for x64 Using python 2.7.6 Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/usr/include/c++/4.2.1 Unable to find a compiler Here’s some logs: Starting from scratch… $ cd ~/Documents/code/website $ rvm gemset empty $ ruby -v ruby 1.9.3p448 (2013-06-27 revision 41675) [x86_64-darwin10.8.0] $ grep rubyracer Gemfile gem 'therubyracer', '~> 0.12.0' $ Are there any rules or guidelines about designing a flag? sudo apt-get install nodejs More information on github: https://github.com/sstephenson/execjs share|improve this answer edited Oct 7 '14 at 22:42 answered Oct 7 '14 at 22:33 Oswaldo Ferreira 7091111 add a comment| up You Have Chosen To Use The Version Of V8 Found On Your System

Similar questions Installing libv8 gem on Mavericks How to fix libv8 error from Gemfile on Mavericks? make: *** [accessor.o] Error 1 Gem files will remain installed in /Users/chris/.rvm/gems/ruby-1.9.3-p448/gems/therubyracer-0.12.1 for inspection. Please post bug reports in Jira. I’m having similar problems, but when I use 0.12.

Messages sorted by: [ date ] [ thread ] [ subject ] [ author ] More information about the freebsd-questions mailing list El Capitan Therubyracer Here is the error code I am getting. ➜ libv8 git:(master) ✗ gem install therubyracer Building native extensions. Please don't fill out this field.

My basic English comprehension skills suggest to me that my GCC version that came with Ubuntu 15.10 is incompatible, so my thought is either find a way to rollback to an

More details on how the problem was solved here: https://github.com/cowboyd/libv8/issues/120 share|improve this answer answered Mar 21 '14 at 16:28 Chris S 4591512 add a comment| up vote 1 down vote It You signed out in another tab or window. Terms Privacy Security Status Help You can't perform that action at this time. An Error Occurred While Installing Therubyracer (0.11.4), And Bundler Cannot Continue. Results logged to /Users/edolyne/.rvm/gems/ruby-2.1.2/extensions/x86_64-darwin-14/2.1.0/libv8-3.16.14.3/gem_make.out dallasbpeters commented Jul 22, 2014 @edolyne I'm still seeing this exact same thing as well.

ERROR: Error installing therubyracer: ERROR: Failed to build gem native extension. /Users/edolyne/.rvm/rubies/ruby-2.1.2/bin/ruby extconf.rb creating Makefile Compiling v8 for x64 Using python 2.7.6 Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/usr/include/c++/4.2.1 Unable to find a compiler beforehand: I installed v8 via brew install v8, and then did gem install libv8 -v '3.16.14.3' -- --with-system-v8 and I am running 10.10 Yosemite share|improve this answer answered Nov 17 '14 We can do that. $ export CXX=/usr/local/Cellar/gcc48/4.8.2/bin/g++-4.8 $ export CPP=/usr/local/Cellar/gcc48/4.8.2/bin/cpp-4.8 $ export CC=/usr/local/Cellar/gcc48/4.8.2/bin/gcc-4.8 $ which $CXX /usr/local/Cellar/gcc48/4.8.2/bin/g++-4.8 $ which $CPP /usr/local/Cellar/gcc48/4.8.2/bin/cpp-4.8 $ which $CC /usr/local/Cellar/gcc48/4.8.2/bin/gcc-4.8 $ bundle install … Installing libv8 Thank you guys, it's installed!

Top Erazoender Posts: 3 Joined: Wed Mar 30, 2016 19:06 Re: Trouble installing ROOT 6 Ubuntu 15.10, GCC cling error Quote Unread postby Erazoender » Fri Apr 08, 2016 23:17 I'm yes checking for main() in -lobjc... Just installing execjs will solve the problem. Reference: https://github.com/cowboyd/libv8/issues/120 share|improve this answer answered Jan 7 '15 at 18:03 srt32 573517 1 FYI...

How to use the binomial theorem to calculate binomials with a negative exponent Why (in universe) are blade runners called blade runners? Not the answer you're looking for? Fixed by completely nuking rvm and starting from scratch, though I imagine you could just uninstall/reinstall the offending ruby. Top ferhue Posts: 195 Joined: Wed Apr 04, 2012 17:40 Location: HZDR Contact: Contact ferhue Website Re: Trouble installing ROOT 6 Ubuntu 15.10, GCC cling error Quote Unread postby ferhue »

Logged Print Pages: [1] Go Up « previous next » Sean Meighan» Welcome» Latest xLights/Nutcracker software» compiling the latest version - what did I mess up - SMF 2.0.6 | The initial poster was not using jruby. Clone in SourceTree Atlassian SourceTree is a free Git and Mercurial client for Windows. Messages sorted by: [ date ] [ thread ] [ subject ] [ author ] Just out of curiosity, I commented out the BROKEN lines in /usr/ports/sysutils/pib/Makefile and tried building the

Can cats leave scratch marks on cars? If you can spot what’s going wrong and help me fix it, you’ll be my hero(ine) forever. make[1]: *** [/Users/edolyne/.rvm/gems/ruby-2.1.2/gems/libv8-3.16.14.3/vendor/v8/out/x64.release/obj.target/preparser_lib/src/cached-powers.o] Error 1 make: *** [x64.release] Error 2 /Users/edolyne/.rvm/gems/ruby-2.1.2/gems/libv8-3.16.14.3/ext/libv8/location.rb:36:in block in verify_installation!': libv8 did not install properly, expected binary v8 archive '/Users/edolyne/.rvm/gems/ruby-2.1.2/gems/libv8-3.16.14.3/vendor/v8/out/x64.release/obj.target/tools/gyp/libv8_base.a'to exist, but it was not found (Libv8::Location::Vendor::ArchiveNotFound)

© 2017 imagextension.com